Impara Excel Come e Quando Vuoi Tu
LinkedIn
Facebook
Twitter
Google+
https://masterexcel.it/conta-se/

Benvenuto ad una nuova lezione di MasterExcel.it. In questa lezione ci occuperemo della Funzione Conta.Se di Excel. Vedremo come si utilizza e a cosa serve.

Che cosa fa la Conta Se?

  • Testa una condizione ed esegue un conteggio
  • Se la condizione è rispettata, è considerata come VERO e conta quei valori che la rispettano.
  • Se la condizione non è rispettata, è considerato come FALSO e esclude i valori falso dal conteggio.

Guarda il Video della Funzione Excel: Conta.Se

Come sempre, utilizzeremo un file di esempio visibile nell’immagine sottostante.

conta.se

Si tratta di una funzione molto simile alla funzione SOMMA SE, ma con una differenza: questa funzione non esegue una somma ma un conteggio.

In questo esempio andremo ad eseguire il conteggio di tutti i numeri inferiori ad uno all’interno della colonna E. Andremo quindi ad utilizzare un criterio numerico, possiamo anche utilizzare criteri di natura testuale.

Per usare la funzione CONTA.SE, ovviamente, dovremo selezionare il nostro intervallo di valori da controllare. In questo caso l’intera colonna E. Poi impostiamo il nostro criterio: “<1”. Ovvero, il nostro criterio è “inferiori ad 1” , come lo è stato in passato per mostrarti la Funzione Somma.Se. Ricordati di inserirlo tra virgolette.

So che è un criterio numerico e non testuale, ma va messo tra virgolette. Se invece il criterio fosse stato “uguale ad 1” non sarebbe servito ne l’uguale ne mettere le virgolette. Sarebbe bastato inserire come criterio il numero 1.

Quindi, in questo esempio, la formula da utilizzare è:

=CONTA.SE(E:E;”<1″)

Il nostro risultato, in questo caso è: 16. Questi sono i numeri minori di uno presenti nel nostro intervallo.

Piccolo Trucco

Voglio svelarti un piccolo trucco!
In questo esempio abbiamo appena scoperto che vi sono ben 16 numeri inferiori ad 1 nel nostro intervallo. Abbiamo fatto il conto con la funzione conta.se! Non possiamo sbagliarci. Sappiamo quanti sono, ma quali sono?

Per trovarli è facilissimo! Possiamo usare la Formattazione Condizionale e evidenziarli in giallo.

Conta.Se – 2° Esempio

Proseguiamo con un altro esempio, utilizzando un nuovo file.

conta.se-02

Contiamo quante volte compare “Spagna” nella colonna A.

Selezioniamo la cella E2 e scriviamo la nostra conta.se:

 =CONTA.SE(A:A;D2)

In questo caso abbiamo inserito come intervallo la colonna “A”, e come criterio la cella D2, ossia “Spagna”. Questa formula ci fornirà il conteggio della parola presente nella cella selezionata.

Come hai notato, non la ho bloccata, in questo modo, facendo scorrere la formula ed utilizzando la funzione di auto-riempimento di Excel, possiamo eseguire anche il conteggio per la parola sottostante, ovvero: “Italia”.

 

Scheda della Funzione Conta.Se:

  • Questo tipo di formula, risulta molto utile nel caso di funzioni SE nidificate. Ma di questo ci occuperemo in futuro.
  • Questa Funzione offre la combinazione delle due funzioni CONTA e SE. Questa combinazione non è altrimenti ottenibile senza una nidificazione estremamente complessa.
  • L’unione delle Comparazioni condizionali con un Conteggio, è pressoché sempre necessario per le operazioni di Data Analysis.

Sintassi funzione CONTA.SE

  • =CONTA.SE(Intervallo;Criterio da rispettare)
  • La condizione è di norma un test tra del tipo A:A;C2.
  • Oppure tra una cella e un valore (Es: A:A;10), nel caso di maggiore di: A1;”>10”. Nel caso di un testo A1;”ok”.

Esempio

conta-se

Conclusioni e Consigli

  • Spesso, al posto della funzione conta se, si può usare il Subtotale o un Pivot per fare la stessa identica cosa, e risparmiare un sacco di tempo.
  • Non si scrive uguale, si scrive solo il valore o la cella come criterio. Es: se come criterio deve essere uguale a 10, non si scrive A:A=10 ma si scrive A:A;10
  • Se non sai immettere il criterio correttamente, scrivilo in un’altra cella poi metti il riferimento ad essa, come nell’esempio. Altrimenti, inserisci il criterio tra virgolette.
  • Vi è una sua “funzione figlia”, la Funzione Conta Più Se. Che valuta più criteri da rispettare per il conteggio.

Per approfondimenti

Se vuoi approfondire: Sito Ufficiale della Microsoft

 

LinkedIn
Facebook
Twitter
Google+
https://masterexcel.it/conta-se/