Impara Excel a Casa Tua - 100% Online

Nella lezione di oggi vediamo il Se Compreso Tra in Excel, funzione che non esiste. Per ottenere una funzione in grado di dirci se un valore è compreso tra altri due (un massimo e un minimo) ci occorrono due funzioni base, la Funzione Se e la Funzione E, ho già preparato per te degli articoli per entrambe queste funzioni che puoi trovare nel Corso Excel Base di MasterExcel.it.

 

Guada il Video: Compreso in Excel

 

I dati

Prima di iniziare diamo una rapida occhiata ai dati:

compreso-in-excel-dati

Abbiamo una prima colonna con dei dati numerici, dall’1 al 13. Nulla di complicato.

Di fianco, nelle celle in verde abbiamo scritto i nostri: minimo e massimo. Da notare: questi sono chiaramente visibili distintamente ed esternamente rispetto ai dati. Possiamo anche inserirli direttamente dentro la formula, ma facendo così essa non sarebbe dinamica e non sarebbero visibili a noi; quindi, “nascondendoli” dentro la formula, potremmo aumentare la possibilità di fare degli errori. Noi ovviamente vogliamo minimizzare gli errori umani e le ambiguità; quindi, poniamo massimi e minimi esterni e chiaramente ben distinti rispetto ai dati.

Prepara anche tu i dati in questo modo, non è difficile. Ci vediamo tra poco con la funzione compreso di Excel.

 

Funzione Se Compreso Tra di Excel

Come detto all’inizio dobbiamo far uso della Funzione E. Questa non è particolarmente conosciuta quindi ti consigliamo di darle l’attenzione che merita cliccando qui. La Funzione di oggi è semplicemente una E, la Funzione Se è utilizzata solo per abbellimento.

Ecco come risulterebbe:

=E(val>=min; val>=max)

Questa Funzione restituisce solo o VERO o FALSO (o errore). Con i nostri dati risulterebbe così:

compreso-in-excel-funzione

Riportiamo qui la formula con i riferimenti nella prima cella dei dati (riga 2 – la 1 è di intestazione):

=E(B2>=$G$4;B2<=$G$3)

Ed ecco una sua variante con i riferimenti di colonna per le nuove versioni (con @):

=E(@B:B>=$G$4;@B:B<=$G$3)

e una sua variante con i riferimenti di colonna per le vecchie versioni (senza @):

=E(@B:B>=$G$4;@B:B<=$G$3)

 

Cosa fa questa formula?

Questa formula esegue in questo caso due test. Controlla se (si, esegue un controllo anche se non abbiamo ancora inserito la Funzione Se) sia il valore è maggiore o uguale al minimo (E) sia se è minore o uguale al massimo. Fa quindi due controlli, e devono verificarsi entrambi perché restituisca VERO. Se solo uno dei due test dovesse non verificarsi, tutta la Funzione restituirebbe FALSO.

Dobbiamo fare molta attenzione ai segni (=, <, >, <=, >=) ed approfondiremo tra poco. In questo esempio stiamo comprendendo i due estremi (massimo e minimi) utilizzando i simboli di minore uguale e maggiore uguale. Volendo escludere i due estremi, possiamo utilizzare i simboli di maggiore uguale e minore uguale. Per maggiori info sui questi simboli clicca qui.

L’ordine dei due test non importa. Quindi possiamo scrivere di controllare prima se il valore è maggiore (o uguale) al minimo, e poi se è minore (o uguale) al massimo; oppure controllare prima se è più piccolo (o uguale) rispetto al massimo e controllare dopo se è più grande (o uguale) del minimo. L’ordine dei test non cambia il risultato.

Ogni volta che utilizziamo test all’interno della Funzione E, dobbiamo specificare nuovamente a quale valore si riferisce. Per questo motivo troviamo il valore in colonna B ripetuto due volte.

compreso-in-excel-formula

Non possiamo fornire questo valore una sola volta. Occorre fornirlo in ogni test.

 

Riferimenti Assoluti per Bloccare Max e Min

I riferimenti assoluti di cella (con i simboli del $) sono necessari perché sia il massimo sia il minimo sono esterni ai dati e con la funzione di auto-riempimento di Excel faremo scorrere la formula per le varie righe. Quindi le celle contenenti questi due valori non devono muoversi nelle man mano che facciamo scorrere.

 

Estremi dell’intervallo compresi?

Maggiore, Minore, Maggiore Uguale e Minore Uguale. So che non è esattamente qualcosa di tutti i giorni, ma cerca di fare un po’ di attenzione a quale intervallo stai inserendo. Se vuoi puoi approfondire i simboli di Excel con questo link.

 

Miglioramento con la Funzione Se

Immagino che anche a te non piaccia vedere solo VERO o FALSO come risultato. Per fortuna puoi “abbellire” la Funzione nidificando con una Se in questo modo:

compreso-in-excel-se

Una funzione di questo tipo:

=SE(E(B2>=$G$4;B2<=$G$3);”si”;”NO”)

Oppure:

=SE(E(@B:B>=$G$4;@B:B<=$G$3);”si”;”NO”)

È in grado di restituire un testo da noi scelto come risultato. In questo caso abbiamo: si al posto di VERO, e NO al posto di FALSO. Ricordiamo che tutti i “test” vanno tra virgolette, e che se volessimo ricevere cella vuota possiamo quindi inserire “” – due virgolette senza nulla dentro.

 

Conclusioni

Oggi hai creato una funzione che non esiste! Complimenti! Noi ci vediamo dentro il corso oppure in una delle nostre lezioni gratuite.