Impara Excel Come e Quando Vuoi Tu
LinkedIn
Facebook
Twitter
Google+
https://masterexcel.it/funzione-o-excel/

Benvenuto ad una nuova lezione di MasterExcel.it. In questa lezione vedremo come utilizzare la Funzione O Excel.

La Funzione O, di per se non serve a niente. Serve solo quando è nidificata con un altra funzione di Excel, tipicamente quando è nidificata con una Funzione Se. Quindi, ti lascio il link a tutte le lezioni precedenti e anche alla Funzione E, “sorella” della Funzione O:

Guarda il Video Funzione O Excel:

Introduzione

Utilizzeremo come esempio lo stesso file della nostra lezione precedente.

funzione o excel

Come vedi in righe 6 e 7, mancano alcuni valori. Cosa possiamo fare nel caso in cui uno dei due valori manchi? Possiamo scrivere “manca uno dei due valori”! Ma come lo facciamo?

Quanto una di più condizioni possibili viene a verificarsi, in questo caso l’assenza di un valore, possiamo usare la Funzione O. In maniera del tutto analoga a sua “sorella” E.

Prendiamo la formula che abbiamo visto nella lezione precedente e inseriamo una Funzione Se, con all’interno la nostra Funzione O subito dopo la Funzione E. La formula sara quindi:

=SE(E(A:A=””;B;B=””);””;SE(O(A:A=””;B;B=””);”mancano dei valori”;SE(A:A=B:B;”sono uguali”;SE(A:A>B:B;$A$1;$B$1))))

Fatto!

Cosa ho scritto nella Funzione O?

TEST: scriviamo la formula se in maniera tale da controllare una delle celle, o la A o la B, è vuota?

SE VERO: scriviamo “mancano dei valori”.

SE FALSO: eseguiamo il resto della Funzione Se nidificata che abbiamo visto nelle precedenti lezioni.

Quindi il comando dato può essere sintetizzato cosi: Se la cella nella colonna A o la cella nella colonna B sono vuote, allora scrivi “mancano dei valori”, in caso contrario esegui il resto della Formula.

Utilizziamo il solito doppio click per estendere la formula. Il risultato sarà quello nell’immagine sottostante:

funzione o in excel risultato

Precisazioni

Nella Funzione O, cosi come nella Funzione E, possiamo utilizzare quanti criteri desideriamo. L’unica differenza tra le due funzioni, è che la Funzione E richiede necessariamente di soddisfare tutti i suoi criteri. Al contrario la Funzione O richiede che venga soddisfatto solo un criterio. Ed entrambe, ripeto, hanno senso solo se nidificate tipicamente con una Funzione Se.

Noi ci vediamo nella prossima lezione e se non lo hai ancora fatto, condividi questa pagina!

LinkedIn
Facebook
Twitter
Google+
https://masterexcel.it/funzione-o-excel/